Home / Bukkit Plugins / WorldGuard Plugin 1.7.4/1.7.2/1.6.4/1.6.2

WorldGuard Plugin 1.7.4/1.7.2/1.6.4/1.6.2

http://img3.5minecraft.net/Mods/Worldguard-bukkit-plugins-0.jpg

WorldGuard bukkit plugins 1.7.4

(v5.9)

WorldGuard is a powerful plugin providing all the little things (and some big ones), and it protects your servers from various problems.

  • Block creeper and wither block damage, falling damage, etc.;
  • Disable fire spread, lava fire spread, ice formation, Endermen picking up blocks, etc.;
  • Blacklist certain items and blocks so they can’t be used;
  • Warn moderators when certain items and blocks are used;
  • Protect areas of your world so only certain people can build in them;
  • Set areas where PVP, TNT, mob damage, and other features are disabled;
  • Protect your server from various ‘exploits’ like magical obsidian creation machines;
  • Disable, or enable, various Minecraft features, like sponges from classic;
  • Add useful commands like an immediate “STOP ALL FIRE SPREAD” command.
  • Enable only features you want! Everything is off by default.

Video:

Bukkit is currently required. In the future, WorldGuard will be available for Forge and other APIs.

Installation WorldGuard bukkit plugins

  1. Install WorldEdit first. (DON’T FORGET THIS)
  2. Download WorldGuard and install it the same way.
  3. Run your server once to generate the files.
  4. Edit plugins/WorldGuard/config.yml to your liking.
  5. Use the comm

Changelogs:

Changes in v5.9:

  • Added a config option to allow explosion flags to only prevent block damage
  • Added allow-tamed-spawns setting, on by default. This will stop WorldGuard from culling tamed animals.
  • Added config option and flag to prevent soil from drying naturally.
  • Added formatting codes, &k/l/m/n/o and &x (reset).
  • Added snow-fall-blocks option to config to restrict snow fall to certain blocks
  • Allow players to add newlines (\n) via command, not just manually in yml.
  • Allow the console to load/save all region managers with one command.
  • Changed entity report format slightly.
  • Check bypass perms for item-drop flag.
  • Check for entities and projectiles removing items from frames too.
  • Fix being able to use bonemeal to turn tall grass into double plants.
  • Fix number of arguments for migratedb command.
  • Fixed addowner/addmember commands adding command artifacts. Specifically, “-w <world>” will no longer be added when using it.
  • Fixed milking cows in protected areas due to changes in Bukkit.
  • Fixed ProtectedCuboidRegion::getPoints() returning points in wrong order.
  • Fixed snowman trails being treated as snow fall.
  • Make /rg list default to own regions if the player doesn’t have permission otherwise.
  • Protected items in item frames in protected regions.
  • Resolved an issue where explosions of type OTHER_EXPLOSION were ignoring the world configuration settings.
  • Send item-use blacklist event when right-clicking entities.
  • Transformed the BlockFadeEvent handler into a switch.

v5.8:

Highlight: Support for MC 1.6.1 and 1.6.2

  • BREAKING CHANGE: This version has been built for versions of Bukkit for MC 1.6.1 and newer. Do not try to use this version of WG on an older Bukkit version.
  • Added support for Minecraft 1.6+. Actual support of new 1.6 additions is dependant on Bukkit. Please use a newer build of Bukkit if, for example, you seem to be unable to add “Horses” to your lists of entities.
  • Added mobs.disable-snowman-trails to disable the trails left by walking snowmen.
  • Added -a flag to /region removeowner and /region removemember to remove all objects.
  • Teleporting is now handled by entry/exit flags. If this is causing people to get entirely stuck inside entry/exit deny regions, set the new setting ‘use-player-teleports’ to ‘false’ in your configuration.
  • Updated formatting for region commands, especially /region info.
  • Changed permissions checking for /region commands to be more consistent, checking for region IDs as a sub-node. This means that if some permissions for some region commands no longer work, add ‘.*’ to the end of permission lines for WG in your permission plugin.

Download WorldGuard bukkit plugins

For 1.7.4/1.7.2/1.6.4

http://www.dl3.5minecraft.net/download.php?file=e4ec01f17d274b33d5df68ff53a79c6f

For 1.6.2/1.6.1

http://dl2.5minecraft.net/download.php?file=95d019aef2d695388dfa005d993ef3b8

Only Jar

http://dl2.5minecraft.net/download.php?file=6c4e77cbac50db687ded11b16137e5d8

For 1.5.2/1.5.1/1.5.0

http://dl2.5minecraft.net/download.php?file=60c7778e6db087886c8a10bc4572811a

Only Jar

http://dl2.5minecraft.net/download.php?file=e148da437f878bee38f415a575f4d43d

Credits: 

  • sk89q
  • wizjany
  • zml2008

About thang phung

Check Also

Holographic Displays Plugin 1.8.3

Features Create floating text lines! Floating icons! Fast and easy to use. Simple API for …