Home / Minecraft Resource Packs / Realistic Resource Packs / Prime Craft HD Resource Pack 1.7.9/1.7.2

Prime Craft HD Resource Pack 1.7.9/1.7.2

Prime Craft HD Resource Pack is presently accessible for Minecraft 1.6.2 and it is made via mooshroomisland. This asset pack is just took the ribbon off new and it keeps tabs on practical landscape yet with a softer cleaner look that will speak to generally Minecraft players. I directly play with this new resource pack and I cannot propose it any higher, it totally reskins everything incorporating the GUI! In the event that you need a strong, realiable resource pack that gets upgrades habitually then download the Prime Craft HD Texture Pack! Also, you might want to know that this pack is coming with a 32×32 resolution.

http://img3.5minecraft.net/RT/Prime-Craft-HD-Resource-Pack.jpg

http://img3.5minecraft.net/RT/Prime-Craft-HD-Resource-Pack-3.jpg

http://img3.5minecraft.net/RT/Prime-Craft-HD-Resource-Pack-4.jpg

http://img3.5minecraft.net/RT/Prime-Craft-HD-Resource-Pack-6.jpg

http://img3.5minecraft.net/RT/Prime-Craft-HD-Resource-Pack-7.jpg

Prime Craft HD Changelog v38:

  • New horse gui
  • New netherrack texture
  • New end stone texture
  • New gold block texture
  • Fixed the glitch causing the side of grass blocks to look weird.
  • Fixed broken download links
  • New red mushroom texture
  • New coal block texture
  • 1.6.2 support
  • added horse armor
  • added horse health bar
  • fixed exp bar
  • added hardened clay blocks
  • added coal block
  • added hay bails
  • other small changes

Installation tutorial:

  1.  Download Prime Craft HD resource pack, download link below
  2. Save zip file into %appdata%/.minecraft/resourcepacks folder
  3. Open game and go to Options => Resource Packs button
  4. Select this texture pack and play!

https://dl.dropboxusercontent.com/u/81799896/Prime%20Craft%20HD%201.6.zip

About admin

Check Also

Wolfhound Resource Pack 1.8/1.7.10/1.7.2

Wolfhound Resource Pack 1.8/1.7.10/1.7.2 Resolution: 64x Developer : ThistlePack Compatible : Minecraft 1.7.2, Minecraft 1.7.10, Minecraft …