Magic Launcher Tool for Minecraft 1.8.1/1.8/1.7.9/1.7.2

Magic Launcher Tool

The Magic Launcher is a new Minecraft launcher which can load mods dynamically without changing or patching the minecraft.jar.

No more mod installation problems, just select your mods and enjoy.

Screenshots:

http://img2.5minecraft.net/mods/magic-launcher-tool-1.png

http://img2.5minecraft.net/mods/magic-launcher-tool-2.png

http://img2.5minecraft.net/mods/magic-launcher-tool-3.png

http://img2.5minecraft.net/mods/magic-launcher-tool-4.png

http://img2.5minecraft.net/mods/magic-launcher-tool-5.png

http://img2.5minecraft.net/mods/magic-launcher-tool-6.png

Features:

  • Minecraft
    • Selectable minecraft.jar
    • Automatic version detection
    • Configurable window size, also maximized
    • Selectable minecraft folder
    • Selectable java executable
    • Java memory limit
    • Java custom parameters
    • Show error log
    • Remember user
    • Configuration profiles
  • Mods
    • Load mods dynamically without changing minecraft.jar
    • META-INF does not have to be deleted
    • Automatic mod compatibility checking
    • External mods detection and compatibility checking
    • Shortcut to external mods folder
    • Configurable external mods
    • Automatic mod requirements checking (ModLoader, ModLoaderMP, Forge, GuiAPI)
  • Design
    • Minecraft style

Changelogs:

v1.2.2

  •  updated to use the Minecraft 1.7+ login protocol
  • added automatic library download, added check for library rules
  • added performance fix for Intel integrated graphics
  • updated server status check, fixed classic environment
  • fixed handling of authentication problems

v1.1.7

  • Fixed missing sound, caused by the sound thread being interrupted while writing log
  • Fixed Forge mod detection when Forge is loaded as environment library
  • Fixed RSS feeds to use cached static files

Note for Minecraft 1.6.2+:

  • To run Minecraft 1.6.2+, go to Setup -> Environment and select 1.6.2. If the Environment 1.6.2 is not available, use the vanilla launcher to download and start Minecraft 1.6.2, then Environment 1.6.2 should appear in the list.
  • To run Minecraft 1.6.2+ with Forge, go to Setup -> Environment and select 1.6.2_Forge_XYZ. If the Environment 1.6.2_Forge is not available, use the vanilla launcher to download and start Minecraft 1.6.2, then use the Forge installer to install Forge and then the Environment 1.6.2_Forge_XYZ should appear in the list.

Download Magic Launcher Tool

For 1.7.x/1.8.x

Windows: Download from Server 1

Mac: Download from Server 1

Windows/Mac/Linux: Download from Server 1

For 1.7+

Windows: Download from Server 1

Mac: Download from Server 1

Windows/Mac/Linux: Download from Server 1

For 1.6

Windows

http://dl2.5minecraft.net/download.php?file=213d644b38d8af82758d888d2388eb12

Mac

http://dl2.5minecraft.net/download.php?file=0833c7b8eace6b17f032dccf08d165f6

Windows/Mac/Linux

http://dl2.5minecraft.net/download.php?file=d09d57e9a63c0d6fbb6598b15f48b837

Old version

Credits: sp614x

 

Tags: , , , , , , , , , , , , , , , , , , , , ,

Get Updates

Related Posts

© 2014 Minecraft 1.7.10/1.7.9/1.7.2. All rights reserved. 5Minecraft is not affiliated with Minecraft or Mojang in any way. Powered by WordPress.